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MS Excel is an example of a spreadsheet, a branch of software meant for performing different kinds 

of calculations, numeric data analysis and presentation, statistical operations and forecasts. The main 

part of a spreadsheet application is a grid consisting of equally (at least in a default view and 

configuration) distributed cells forming rows and columns. The rows are denoted by numbers (from 

1 up to 65536, i.e. 216) and the columns by letters (from A to Z, then AA, AB up to IV, which makes 

a total number of columns equal to 256. i.e. 28). The cells are called by column and row identifiers, 

e.g. A3, G45, etc. 

 

 

Active cell selection can be performed by means of mouse (simple clicking or keyboard arrows). The 

same refers to making a range selection (Ctrl and Shift keys are useful, especially in case of a 

discontinuous selections): 

 

Note:  Please open excel file "EXCEL2010.xlsx" and save it as "lab_excel-studentname.xlsx" on 

the PC . DO EXERCICES IN THE SPREADSHEETS ALREADY CREATED IN THE FILE. THEY 

HAVE EXPLICIT NAMES RELATED WITH THE NUMBER OF THE EXERCICES (E.G. 

SPREADSHEET Exercise3-7 FOR EXERCISES 3 TO 7 DEFINED BELOW) AND MAY CONTAIN 

DATA TO SAVE TIME. 

Exercise 1 
Open spreadsheet Exercise1 and check different selection techniques. Try to make a selection as in 

the picture above. Check possibilities to select the whole tow/column by clicking on its header. Select 

multiple rows/columns, also discontinuously as in the picture below. Finally, select the whole 

worksheet by clicking on the upper-left corner (where row and column headers overlap, equivalent 

to Ctrl+A key combination). 
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The most common way to enter data into a worksheet is just typing it. Accepting the cell value is 

done by: 

 pressing Enter key (this moves the active cell one row down, useful when entering some column-

sorted data), 

 pressing Tab key (this moves the active cell one column right, useful when entering some row-

sorted data), 

 pressing any keyboard arrow, 

 clicking somewhere outside the active cell. 

In order to delete the cell content, make it active and just press Delete key or Backspace key (this 

removes cell data and starts its edition). 

 

In case of cell edition, also select it as active. By double-clicking (equivalent to pressing F2 key), you 

start editing the data within the cell. If you want to overwrite current cell data, just start typing on it. 

However, very often it becomes more convenient to edit the cell data in a formula bar: 

 

 

 

 

 

Excel makes maximum effort to recognize data type (e.g. text, numeric, currency, date), which feature 

is usually ;) very useful and convenient. In case of each data type it applies appropriate alignment 

and some predefined display formats. Be careful about the data types recognized by the software 

while entering data, as sometimes it is very difficult to change them. 

 

 

 

 

 

formula bar 

active 
cell 

active cell 
coordinates 



Introduction to CS lab 

MS Excel 2010 

Laurent Babout, lbabout@iis.p.lodz.pl  

Abdulla Juwaied, ajuwaied@iis.p.lodz.pl 

 

page 3 of 15 

 

 

Exercise 2 
Enter the data below in spreadsheet Exercise2. Format the data so that they look as a table (change 

fonts, borders, shading, override default alignments, etc). Add some dummy header. Try also 

formatting the table using Format as Table button from the Styles group (try two of the four styles 

shown below). 

 

  
 

WARNING: REMEMBER TO OFTEN SAVE YOU WORK. WE NEVER KNOW WHAT CAN 

HAPPEN DURING THE LAB. 

 

Exercise 3 
Use the table already created in spreadsheet Exercise3-7 (see below): 

 

 
 

Then enter the appropriate formula in the cell corresponding to average salary value: 

 

 
Formula 
result 

Cell 
range Formula 
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Hints: 

1. Select a cell where the formula is to be entered. 

2. If you already know the formula syntax (and the function name) you can directly type 

it in the formula bar (always prefix the formula with an equality sign '='). 

3. Otherwise, choose the your formula from the large list of built-in functions available 

from the Formulas tab. 

 

You can select your function from the different categories or press on the function button . 

The dialog containing function group appears: 

 

 

4. Choose appropriate group (Statistical in case of AVERAGE function) and the function 

itself. The another dialog shows, where you can enter the function arguments (e.g. cell range): 

5. Click the range button and select the cell range (MS Excel will attempt to suggest the 

right range): 
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6. Accept the range and the formula. 

 

Format the cell to 2 decimal places: 

 
 

Copy the formula to the adjacent cell corresponding to the average practice. Notice, that the cell 

range in the formula bar is also shifted (as the cells are): 

 
 

 

Calculate the maximum salary and practice using MAX function. Finally, apply the best fit to all the 

columns. Keep the table for the next exercises (4-7). 

Range 
button 
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Exercise 4 
Enter the following data set (in column J): 

 
In the right column (K) enter the formula increasing cell value by 10 (e.g. =J2 + 10). Remember, that 

it is enough to enter the formula in one cell, then drag it over other cells. The result is presented below. 

 
Select the whole data set (J2:K6) and drag it so that it starts in cell L5. 

 
As shown in the above picture, each cell was shifted 2 columns right and 3 rows down. The values in 

the formula column do not change – this means that the formula were correctly translated, so that 

they refer to the appropriate cells. The first cell formula (formerly referring to the cell J2) now refers 

to the cell L5, i.e. =L5 + 10. 

Select only the column with formulae. Move it for example as in the picture below. Notice, that none 

of the formulae changes, as the cells they refer to remain in the same location: 

 

 
 

And now for something completely different :-) Move only the reference cell. See, that all the 

formulae adjust to the new cells' positions: 
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In the above exercises, the functions used as their arguments cell ranges, e.g. in 

MAX(E3:E9) the cell range is E3:E9. The range is denoted as the top-left corner cell, colon, 

the bottom-right corner cell. In the case of single column ranges, only row numbers change in 

a range limit. Similarly, for single row ranges only the column letter changes. 

Notice, that in either formula there appeared relative cell references. This means, that 

when copying the formula, or moving the cell with the formula, the cell references are shifted 

(translated) in the same manner as the cell corresponding to its base location. 

The absolute cell references refer always to a stated cell (sometimes only a row or a 

column). They are denoted with $ preceding a column and/or row, e.g. $A$3, $B5, G$29. 

` 

Exercise 5 
Having the data set and the formulae from previous exercise (move it again to columns A and B), 

modify the formula in the first row in the following way =$J$2 + 10. Propagate the formula over 

other cells containing the formula: 

 
Check the copied formulae. In each there is the reference $J$2. It remains constant during the copying 

process. Try data range manipulations as in the previous exercises and compare their results. 

Exercise 6 
Use the table from exercise 3. Create an additional cell containing a value equal to 500. Using a 

formula with an absolute reference, give each employee 500 raise. Of course, the new salary must be 

placed in a new column: 

  
The following steps will format the sheet in a way enabling us to hide from the users unwanted data. 

At first, move the data range with the previous salary somewhere outside the table. Do the same with 

the raise cell (place it in the same column as the previous salary). Formulae will by automatically 

new salary 
(formula) 

raise 
amount 
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updated: 

 
 

 

Now fix the new salary in the table and apply the formatting: 

  
Check the formula for the average and maximum salaries. Which cell do they refer to? If the reference 

was translated and still binds the previous salary, correct the formulae. 

 

 
At the end, click on the column with the previous salary and the raise. Try deleting the values of cells 

involved in the formulae. Since a numeric value of an empty cell in MS Excel is 0 (zero), the formulae 

results are recalculated: 

 
On the other hand, if you delete the cells (the whole column or only the range), an error of invalid 

address is returned from the formulae: 

updated formulae's 
results 
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Since the values from the cells referred to in formulae must exits in the worksheet, you may not delete 

them. However, in most cases it is enough to hide a column or a row with “spare” data. Do it by 

selecting the column and choosing Hide from the context menu. Try also to unhide the hidden 

column: 

 

 
 

Exercise 7 
Use the same table, but now look at the 2 empty columns bonus and new salary. Write 2 formulae 

enabling to determine employee's practice bonus (e.g. 2 % for each 5 years, with maximum 12 %) 

and the total salary in the adjacent columns. The workbook may look as in the picture: 

  
Hints: 

1. Use nested IF function: IF(condition;[if true];[else]), where [else] clause is another IF 

function. The syntax should be like in the example: 

 

 

 

=IF(F2 >= 30;0,12;IF(F2 >= 25;0,1;[put here another nested IF function])) 

 

 

formula 
error 
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formula 
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contition value if true (bonus = 0,12) 

value if false, here another IF function 
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2. References to another worksheet cells are denoted as [worksheet name]![cell 

address], e.g. Sheet1!F32. The expressions should look like this: 

=(1+Sheet2!D2)*Sheet1!C2 

You can type the references or click on the appropriate cell in another worksheet while entering 

the formula. 

 

Exercise 8 
Use the table already created in spreadsheet Exercise8. In the third column create a formula displaying 

initials of the people: 

 
Hint: 

The functions required in the formula are: 

CONCATENATE(text1;text2;...) - concatenation of text1, text2, .... 

MID(text,starting_character;number_of_characters) – substring of text starting at 

starting_character (the first one is 1), number_of_characters long, e.g. 

MID(“some text”;2;6) retrieves “ome te”. 

 

 

 

 

 

MS Excel 2010 offers a large set of graphs and plots for data visualization. For those who are familiar 

with older version of Excel, the layout is completely different. The following exercises demonstrate 

different graphs and the set of operations to create and manipulate them. 

 

Exercise 9 
Now, move to spreadsheet Exercise9-10-12. You will notice that a column is already created with 

values ranging from -10 to 10 with a step of 0.5. Be aware that you should know how to create such 

column automatically. Ask the teacher if you need help. 

Enter the function 𝑓(𝑥) = 𝑙𝑜𝑔2 ∣ 3𝑥 + 1 ∣in column B. Here, the variable x corresponds to cell values 

in column A and f(x) corresponds to corresponding function values in column B. 

Create a line plot of the function. 

Hints: 

1. Select the whole data range and click Insert tab, then on the Scatter button from the 

Charts group. Then select Scatter with Smooth Lines and Markers from the different plot 

choices (If it does not work, simply select Marked Scatter, then select points in chart, click 

right and select Format Data Series): 

formula 
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A default chart is inserted to the worksheet. Remember, the 1st column corresponds to the 

abscissae, the 2nd one to the ordinates. Alternatively, you can choose the chart type from the 

Insert Chart dialog box when you click on the little arrow at the bottom-right hand side of the 

Charts group. 

2. You can now notice that the menu bar as changed its display, with a Chart tools banner 

appearing above the Design, Layout and Format tabs. When a chart is activated, you can 

change its display by accessing one of these tabs. 

 

3. A chart is composed of different components. All of them are displayed in a drop-

down list in the Current Selection group of the Layout or Format tab. For instance, a default 

chart, as shown below, is composed of the plotted series, a plot area, value axes, grid lines, a 

chart area and a legend of the series. 

graph groups 

graphs in the group 
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However, it can be more detailed by adding a chart title and the axis titles. Each items can be 

edited. They can be accessed from the drop-down list mentioned above, or simply by clicking 

on them. To change their properties, either choose options from the toolbar, open the Format 

“item” Dialog box (e.g. Format Axis) by clicking on Format Selection of the Current 

Selection group or from the context menu. 

 

Exercise 10 
Based on the information provided above, format the plot from the previous exercise so that it looks 

like in the example below: 
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Move to Exercise11 spreadsheet and  create the column chart basing on the values: 

 

Hints: 

1. Insert one of the default bar types which corresponds the best to what is needed, then 

you can click on the Switch Row/Column button of the Data group displayed in the Design tab 

to change the series. 

2. In the Plot Area, the different sides of the 3D view are called floor, side and back walls 

in the component drop-down list. 

3. Select each data series and change its color. 

 

 

Exercise 12 

Go back to the worksheet corresponding to Exercise9-10-12 and add to the chart a new plot  

corresponding to the function f(x)=exp(x/10) (function f2).The updated worksheet should look as 

follows: 

 

Hints: 

1. to add a new series to the chart, click on the Select Data button . In the Select Data 

Source dialog box, click on add, then select the right series name, X and Y values. Update also 

the name for the column B (i.e. f2). 

2. Add an Horizontal Axis Title. 

3. Modify the chart/plot styles to match the example as much as you can. 

Exercise 13 
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The measured data very often contains some error. Go to spreadsheet Exercise13-14  and create the 

scattered plot (select column B-C). Add the trend line, assuming the most accurate approximation. 

Indicate also the standard error bars (or any error type you assume in the measurement): 

 

Hints: 

 

1. You can insert a trend line from the context menu or by clicking on the Trendline 

button (Layout tab), then select More Trendline Options... 

2. Use polynomial approximation (degree: 3) for the trend curve. Display also the 

equation and the R2 value on the chart 

3. To embed the arrow, go to the Insert tab and click on Shapes. Modify the style in 

consequence. 

4. Verify that the arrow moves with the chart 

 

Exercise 14 
Using the embedded Solver is another way to fit a given function to a set of scattered values. If 

the Solver is not yet installed, proceed as follows: 

 Go in the File → Options → Add-ins 

 Select Solver Add-in and click on the Go button 

 Check Solver Add-in and click OK 

 You can find the Solver on the Data tab 

 

In the  spreadsheet Exercise13-14, add a new polynomial function of order 3 for the given 

domain interval (column B “x”), e.g. in column D. Prior to this, set the 4 polynomial constants 

to arbitrary values and called them in the function using absolute referencing. 

In a new column, set the absolute difference between the scattered data (column C “y2”) and 

polynomial function, e.g. in column D. Then set the sum of the column. This is the parameter 

you will minimized in solver, while changing the polynomial constants. 

To do so, open the Solver window and do the following steps: 

 Link the “Set Objective” to the cell where you calculating the sum of the absolute 

difference 

 Select Min, to have the Objective Cell as small as possible 

 Set the “Changing Variable Cells” to the range of cells where you defined the 

polynomial constants 

 Uncheck the “Make Unconstrained Variables Non-Negative” check-box 
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 Select the “GRG nonlinear” solving methods 

 Press “solve” 

 

Compare the results of the optimized polynomial constants with the ones from the trend line. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 


