Introduction to CS lab 2b Jacek Wislicki, jacentv@kis.p.lodz.pl

Page layout and graphics Laurent Babout, [babout@kis.p.lodz.pl

Word processors offer many facilities for making the page layout more flexible and capable of
displaying different kinds of information. In the previous exercises there where discussed some

ways to format paragraph text and tables. In the following laboratory there will be given general
aspects of page formatting.

Exercise 1 - the only exercise, but a very looooooooong one
From the Page Setup group from the Page Layout tab, setup the page dimension to A5 (148 & 210
mm) landscape and the margins to 12 mm each. Ignore MS Word warnings if any. Set the page

border so that it looks similar to the example below (Page Layout tab then Page Boarders from
Page Background group):

Set the column count to 2 equally distributed with 10 mm spacing and a line separator from the
Columns dialog box that you can open if you select Columns — More Columns...:
Columns @‘éj‘

Presets
One Tuwo Three Left

Right

Right-to-eft
Number of columns: |2

7] Line between
Width and spacing Preview
Col #  Width: Spacing:
8aem [ [1em
8,8 cm
1

| Equal column width

Apply to: | Whole document |Z| Start new column

Add a header from the Insert tab (Header — Edit Header). The display of the Design tab changes
as shown below:

E: H9- |= pader & Footer. Tools Document2 - Micros
Haome Insert Page Layout References Mailings Review View Design |
j j j ﬁ j EE ; (5, Previous [ Different First Page 3+ HeaderfromTop:  1,25em 3
| = # by | |oal @R = 2 e h [ %]

[T Different Odd & Even Pages | [ Footer from Bottom: 1,25em -
Header Footer Page Date Quick Picture Clip Goto = ) Close Header
- *  Mumber~ &Time Parts~ Art Footer [¥] Show Document Text ] Insert Alignment Tab and Footer
Position I Close

Header & Footer Insert Mavigation | Options

Insert into header a table with no border and add a text as in the picture below (replace the sample
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text with your data). To insert the table, simply stay in the editable mode of the Header/Footer, then
click on the Insert tab and apply instructions from the previous lab (i.e. lab 2a). To see the border
line in the editable mode, select View Gridlines from the Table group:

UTILITY -SOFTWARE -LABORATORY>
1
Header |||

i
"“ Name:-YourNameZ Faculty:-Your-Faculty= Year: -}'earﬂfstud}':ﬁ

Go to the footer and in a formatted table add the date and page number(s). For the latter, in the
Header and Footer group of the Design tab, select Page Number — Current Position (if your
cursor is already at the correct place) — Page X of Y. After, modify the style in consequence:

Fosgpr |
[ 2011708704 [ p.- '“’“:1111

A

(page number (total number of pages))—’

Choose Times New Roman for the font of the heard/footer. If the header or footer do not seem to
match the page layout, fix their respective postion from the Position group of the Design tab. Close
Ed

the Hear and Footer ==« .The page should look as follows:

Name:-YourNamez Faculty:-Your-Faculty= Year:year-ofstudy:
UTILITY -SOFTWARE-LABORATORY®=
bl

il

Copy the text from the sample text file and paste it into your document. Format the text as in the
given example (The paragraph text is Times New Roman 10, justified, 1.5 cm first line
displacement, single line spacing. The heading text is Arial 12, justified, bold, 6 pts spacing before
and after).

Hints:

1. Title, paragraphs and numbered items (“Section” titles) should be formated by means of
predefined MS Words styles (i.e. Normal and Heading 1), with some font size
modifications, paragraph and level numbering where needed. To do so, show the Style
window by clicking on = | in the Styles group of the Home tab. Put the cursor on a chosen
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style (for instance Normal), it is changed in a drop down list as follows:

4 Find ~
AaBbCeDd!  AaBbCcDdl  AaBbCeDdE 4
- Sac Replace
Emphasis  Intense E..  Stron | Change
P 9 17| styles~ | b setect~
Editing
Styles 2 E3
-
Clear Al b
abstract T
.
Year:-yearof-studys "
Update Normal to Match Selection

M Modify...
3- Algorithm- (HCA),-is-
s-in-a-3D-object,such Select All: (No Data)
-method-is-based  on- Remove All: (Mo Data)
topological- number,-
nts- that- are- conumon-
5-17] -Greneral-details- Rermnove from Quick Style Gallery

-a-2D-ilustration-of-a- | | ” Subtitle b}
e i e A A ain. Suihte Fmnhasis a

Click on Modify... to open the Modify Style dialog window (see below). Modify in
consequence the style to reflect the example below and access the different attributes (eg.
Font, paragraph, Numbering...)by clicking on Format.

Delete Normal...

Modify Style a ?
Properties
Name: Normal
Style type: Paragraph
Style based on: (o style)
Style for folowing paragraph: | T Normal =1k
I'| Formatting
| Times NewRomen [+] [0 [+]| B 7 © Automatic | |[Latn [~
| = == Bl = =412 | &= =

1t is clear fom Table 1 that once formed the area of the three bridges sb decresse significantly in size
barwzen sucesssive scans as they il The bridzs filuse sate would be expecred to depend on the crack opening
displacemant. 25 the bridges filin

Font: (Default) Times New Roman, 10 pt, Complex Saipt Font: +Body CS (Arial), Indent:
Firstline: 1,5 cm, Left-to-right, Justified |
Line spacing: single, Widow/Orphan control, Style: Quick Style

| [¥] Add to Quick Style list

|| @ Only in this document () New documents based on this template i
Il (|
| (|
e Eont... i

- Paragraph...

2. Use the bulleting or numbering where required (i.e. Heading 1). This means that section
numbers cannot be entered manually (if they are already added to the text prior to
formatting, delete them).

3. Remember about paragraph indents and spacings (especially for the abstract formatting).
Do not use spaces and end-of-line signs in order to achieve the given result. For the
abstract formatting, create a new style. To do so, click on at the bottom of the Style

window. Name this new style ,,4bstract” and make the change in consequence as in the

example below. Create also a new style for the references if they exist in your sample
text file, based on Normal style but with the 2 following attributes: no indentation, no

first line displacement.
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Name:-Your-Name: Faculty:-YourFacultys Year:-yearofstudy:
UTILITY - SOFTWARE-LABORATORY™
[
A-method-for-the-3D-quantification-of- detailed- in- several- review- articles- [1.- 2].- Examples- include-

bridging-ligaments- during-crack- propagationy] | fatigue crack: growth in-alumipium-alloys-[3-5], and TV§iC
fibre-composites-[6-8]-as-well-asintergranular-stress-comosion-
cracking-(IGSCC)-in- austenitic-stainless-steel-[9-11].-In-each-
case,- tomography- allows- study- of- the- mteraction- between-
cracks- and- their- swrounding- microstructure.- Further- the-
future-design-and-optimisation-of-exciting newmatenals-such-

Abstracty
This- paper- shows- how- a- Hole- Closing-
Algorithm-can-be-used-to-identify-and-quantify-

crack-bridgingligaments fram-a-sequence-of-X- as- selfrepairing- materials- and- hierarchical- biomimetic-
ray-tomegraphy-images-of intergranular-stress: materials- will- require- better- knowledge about- the- crack-
corrosion- cracking.- This- allows- automatic- shielding- mechanisms.{

quantification- of the- evolution- of bridging- In- each-case-of damage- accumulation-the- crack-

ligaments- fhr?a{gh- the crack: propagaiion path-is-interrupted,- deflected- and-bridged - These-slow down-
sequence providing - fracture-mechanics-insight- crack- propagation- and- can- increase- the- materials-lifetime -
previously- unobtainable- from fractography.- Quantifying: the- effects- of- these- bridging- zones- in- 3D- is-
D_‘lg'mf;md'm '0'35_0'03"1’.??:*3‘2110'?mgr'f’i’mg' therefore: becoming: increasingly- important. - Isolating- such-
dimensional- materials- science-problems,- such- features- from- the- rest- of- the- microstructure- is- key- to-

asclosing walls-infoams. | quantifying- their- morphological- properties- (e.g.- shape.-size,-

1 orentation) and- their- microstructural- properties- (2.3

k 1 sIntroduction . crystallographic- onentation).- This- information- can- then- be-
incorporatedinmodels,-suchasthe FEM-approach-developed-

In-the-last-decade,-the-focus-on'mapping-damage- by-Jivkoy-et-al [12]to mimic the real 3D-hehavigur-of-cracks-
processes in-engineering-matetials-has-increased-steeply, due- and-to-predict- crack- growth-rates.- The-reliable-extraction-of
in-partto-the-power-of-emerging-analytical techniques-such-as- bridging-ligaments- from-tomography-data-requires-an-image-
Kray-microtomegaphy-and-partly-to-the-emergence-ofnew- processing- strategy.- Standard- methods,- such- as- histogram-
damage- tolerant microstructired- materials.- As- a- pon; based- segmentation,- will' not- izolate- the- bridges- from- the-
destmuctive method-of-observing-structure-in-3D, tomography - matenal - Indeed,- after- segmentation- of- the- crack,- bndges-

is- well- suited- to- the- study- of- damage- accumulation,- as- comespond-to-holes- (or-tunnels)-in-the-crack-and-are-part-of-

When the text is ready, add to the document the images: lab02b imgl.jpg, lab02b _img?2.jpg,
lab02b_img2.jpg, lab02b img4.jpg.
Hints:

You can do in a few ways. The most common are:

1. Copy the image and paste it in the appropriate place in the document.

2. Drag it and drop in the appropriate place in the document (the picture should be saved to a

local drive before).
3. Use Insert tab — Picture — From file... and point the image file you need.

Scale your images so that they fit the column width (by dragging the image sides or corners or the
Format dialog from the context menu). The all images should be centred. The image placements
and captions should be:

Fig. # Picture Placement
1 lab02b imgl.jpg | after section 2
2 lab02b img2.jpg  |before 2™ paragraph, section 3
3 lab02bh img3.jpg | within section 3 (page 5)
4 1lab02b_img4.jpg | before section 4
Hints:

1. The image captions should be formated using MS predefined image caption style. In
order to do it, select an image, and insert a caption from context menu or from
References tab (Insert Caption from the Captions group).
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Caption

Caption:

Options

Label:  |Fig.

Position: | Below selected item E|
[T Exclude label fram caption

[ New Label... | [ Delete Label ] [ Numbering... ]

[ autocaption... | [oc [ canee ||

,F1g.” label does not exist by default. You will have to create it after clicking on New

Label...

After placing the first caption adjust its formatting as in the example ( Caption style).

. OPTIONAL: figures are usually referenced in the text. Either the reference to a figure
can be entered manually or automatically. In the latter case, place the cursor where
figure or fig. is mentioned in the text (you can use ctrl+F to search for fig* in the text),
select Cross-reference from the Caption group, and select Fig. From the Reference
type drop-down list. Then select the desired figure and omit to insert the caption text
(i.e. Select Only caption and number from the Insert reference to drop-down list

[98)

Name:-Your-Namez: Faculty: Your-Faculty:
UTILITY - SOFTWARE-LABORATORY:

LIl

Year:yearof-study:

the- sumrounding- background.- Since- algonthms-to-close-holes- respective- simplified- skeleton- (in- black).- HCA- considers- a-

in-3D- objects- exist, these-may-be-used-to-extract-bridges.-In-
this- paper- such- methods- are- extended- to- quantify-bndging:
ligamentsin-tomograms-of IGSCC.Y

r 2.+Methodology .
[ I T 11 TTTTTT] T

The- problem- of- hole-closing- is- considered- in-the-
literature- within- the- general- topic- of- repaiting- 3D- models.-
Several methods- have- been- developed-recently-to- comect-
defects- in-isosurfaces- and-3D-meshes,- as-surveyed-in-[13].-
Cme- approach,-called-the- Hole- Closing- Algorithm- (HCA).-1s-
particularly - well- suited-to- finding-holes-in-a-3D-object,-such-

List Paragraph style: indent 0.5 cm before
and 0.4 cm hanging

IS = CTETTETET T

TToepT =TT
of- HCA-are-given-below,-supported-by-a-2D-illustration-of-a-

crack-shown-in-Figure- 1 -with-two-branches{in-grev)-and their-

bounding-box-X-containing: an-object-of interest-0O0I-(e.g.-a-
portion- of- a- crack- containing-a-bridge-as-in-Figure- 1).- The-
method-processes- the- pomts- of X-that- do-not-belong-to-the-
OOL- Topological- number- plays- a- findamental-role- in-this-
approach-and-can-be-described-as-follows:-it-is-a-calculation-
of* the- number- of connected- components- surounding- a-
particular- voxel- p- in- a- 3x3x3- cube- sumrounding- p.- This-
number- is- calculated- both- for- an- object- O (Tp.0)- and-the-
background- (or- complementary- object): B- (TpB).- It- is-
illustrated- in- Figure- 1- where- each- pixel (or- point)- in- the-
images,-excluding those-of the-skeleton, -isrepresented-by the-
comresponding: topological- numbers- with- the following-
notation:: -,-where-D-is-the-squared-Euclidean-distance-from-
the-closest-point-of-the-O0I-(here-the-skeleton).-It-should-be-
noted:T
—tpoints: that- have- Tp.B- = 0- are- called- intenor- points-
since-they haveno-connection to the-background. If-an-
interior-pointis-deleted, it-leaves-a-cavity inthe-object
—ta-point-on-a-line-is-a-1 D-sthmus-while-an intenor-point-
on-a-planeis-a-2D-isthmus thesehave-Tp,Olargerthan-
2-and-Tp.B larger-than-2, respectively .- In-other-words,-
if-a- 1D-isthmus-is-deleted, it-cuts-a-line-into-two-parts.-
If-a-2D-isthmus-is-withdrawn, -it-merges-locally-at-least-
two-connected-components-ofthe-background T

Go to the beginning of the document. Place the cursor just before the title. Add the column break
(from Page Layout tab in the Page Setup group, select Break — Column or press

Shift+Ctrl+Enter). Place the headings for the contents index and the figures index.
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Name:-Your Names Faculty: YourFaculty= Year: yearof study:
UTILITY:SOFTWARE -LABORATORY:
L1l
CONTENTS:] A-method-for-the-3D-quantification-of-
i bridging-ligaments-during-crack- propagationf

...................... Column Break. o ooeeeoeeeeeen . Abstract(
This- paper- shows- how- a Hole- Closing-
Golumn break
B L R ot e e R A L L e e
Hray-nucrotomegmaphy-and-partly-to-the-emergence-ofnew-
damage- tolerant- microstructured- matenals- As- a- non:

destnuctive method-of-observing-structure in-3D, tomography-
is- well- suited- to- the- study- of damage- accumulation,- as-

After each heading (from the Reference menu) add the appropriate indices (Table of contents and
Table of figures).

Name: Your Name Faculty: Your Faculty Year: year of study
UTTLITY SOFTWARF LABORATORY

CONTENTS: A method for the 3D quantification of
10 Inro@uetionh .o 1 bridging ligaments during crack propagation
2. MethodoloZy ..o 2

Abstract
This paper shows how a Hole Closing
Algorithm can be used to identify and quantify
crack-bridging ligaments from a sequence of X-

3
4. Conclusion.

FIGURES: ray tomography images of intergranylgr siress
Fig 1. 2D illustration HCA e 2 corrosion cracking. This allows automatic
Fig. 2. (a) 2D reconstructed images of a portion of the quantification of the evolution of bridging
IGSCC (HS0SUITACE oo eeee e eeee e erene e erene e erens e e e 4 ligaments through the crack propagation
Fig. 3. Example from an image sequence, which presents the sequence providing fracture mechanics insight
CTACK PIIMIE. L.t 6 previously umobtainable from fractograniy.
Fig 4. Evolution of <dcf> and <sh>wvs. fo . 7 The method may alse be applied to other three-

dimensional materials science problems, such
as elosing walls in foams.

1. Introduction

In the last decade, the focus on mapping damage
processes in engineenng matenals has increased steeply, due
in partto the power of emerging analytical techniques such as
XK-ray microtomography and partly to the emergence of new
damage tolerant microstmuctured materials. As a non,
destuctive method of observing structure in 3D, tomography
is well suited to the study of damage accumulation, as

Hint:
Each index should be manually refreshed every time the document contents changes (from
the context menu item Update field).

Finally, format the tables styles (as ordinary paragraph text), for example as shown below:
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MName: Your Name Faculty: Your Faculty Year: yearof study

UTILITY SOFTWARE LABORATORY

CONTENTS: A method for the 3D quantification of
1., Introduction...ievresrsanssnrsansnnrsnnss 1 S - - -
bridging ligaments during crack propagation
2., Methodology ... .o niinnnnnnnnnns 2
3. Resu'lts- .................................. 4 Ahstract
4, ConcTusSTon cuviiv s r s ssnrsansnsnrnnns 7 This paper shows how a Hole Closing
FIGURES: Algorithm can be used to identify and quantify
Fig. 1. 2D illustration HCA. ................ 2 crack-bridging ligaments from a sequence of X~
Fig. 2. (a) 2D reconstructed dmages of a ray tomography images of intergranular stress
portion of the IGSCC (b)isesurface......... .4 corrosion cracking. This allows automatic
Fig. 3. Example from an image sequence, which N N = R P
presents the crack print. .........cceuvuvennn 6 quantification of the evolution of bridging
Fig. 4. Evolution of <dcf> and <sb= wvs. fc.. 7 ligaments through the crack propagation

sequence providing fracture mechanics insight
previously unebtainable from fractography.
The method may also be applied fo other three-
dimensional materials science problems, such
as elosing walls in foams.

1. Introduction

In the last decade, the focus on mapping damage
processes in engineering matenals has increased steeply, due
in partto the power of emerging analyticaltechnmiques such as
Hray microtomography and partly to the emergence of new
damage tolerant microstructured materials. As a non-
destructive method of observing structure n 3D, tomography
is well suited to the study of damage accumulation, as
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